Browsing violations

In this section, you will learn how to use MStyle Violations and Problems views to browse results of the check performed in the previous step.

Browsing violations in MStyle Violations view

  1. By default MStyle Violations view is activated after every check run. However, if it is not visible, open it using Window > Show View > Other... > MStyle Violations menu.
  2. The view presents found problems categorized in groups.

    Violation groups in MStyle Violations view

  3. Select Function parameter is never used group and press Show Violations button (Show Violations button).
  4. Now you can see the list of particular problems.

    Violations list in MStyle Violations view

  5. Select first violation from the list and double click to open it in Magik editor.

    Violation in Magik editor

  6. In MStyle Violations view press Show Groups button (Show Groups button) to show groups again.

Browsing violations in Problems view

  1. Activate Problems view. If it is not visible, open it using Window > Show View > Other... > Problems menu.
  2. Press View Menu button (View Menu button) and select Group By > Type.

    Group By Type command

  3. Expand MStyle Problems group to see all violations.

    Problems view

  4. Select first violation from the list and double click to open it in Magik editor.

Related concepts

Rules and Violations

Related reference

MStyle Violations view
Problems view