File actions

File menu commands:

Name

Function

Keyboard Shortcut

New

Creates a Magik element or a new resource. Configures, which elements are shown in the submenu in Window > Customize Perspective. In Magik Development perspective, this action allows to create a project, a product, a module, a source file or a load list.

Alt + Shift + N

Open File

Opens a file from the file system in the editor.

 

Close 

Closes the current editor. If the editor contains unsaved data, a save request dialog will be shown.

Ctrl + W

Close All

Closes all editors. If editors contain unsaved data, a save request dialog will be shown.

Ctrl + Shift + W

Save

Saves the content of the current editor. Disabled if the editor does not contain unsaved changes.

Ctrl + S

Save As

Saves the content of the current editor under a new name.

 
Save All Saves the content of all editors with unsaved changes. Disabled if no editor contain unsaved changes. Ctrl + Shift + S
Move Moves a resource. Disabled on Magik Elements. To move Magik elements use Refactor > Move (with updating all references to the file) or Edit > Cut / Paste (no updating of references).  
Rename Renames a resource. Disabled on Smallworld™ GIS file elements. F2
Refresh Refreshes the content of the selected element with the local file system. When launched for no specific selection, this command refreshes all projects. F5
Print Prints the content of the current editor. Enabled when an editor has the focus. Ctrl + P
Switch Workspace Switches to another workspace.  
Restart Restarts the application.  
Import Opens the import wizard dialog.  
Export Opens the export wizard dialog.  
Properties Opens the property pages of the selected element. Alt + Enter
Exit Exits application.