Creating your first Magik project

In this section, you will create a new Magik project.

Getting Sample Code (environment_manager)

First you need to download environment_manager source code.

  1. Click here to download environment_manager source code.
  2. Save the archive (do not extract) to a directory from now on referenced as <Downloads>.

Creating project

  1. Click File > New > Magik Project to to start New Magik Project wizard:

    New Magik Project wizard

    In this dialog: Click Next.
  2. Mark checkbox by swaf session to assign it to the project. Then click Finish.

    New Magik Project wizard

    Note: creating swaf sessions was covered in this tutorial.
  3. In Product Explorer select environment_manager project
  4. Select menu item File > Import....
  5. Click Browse button next to Archive file field and select

    <Downloads>/environment_manager.zip

    Note: This step assumes that you followed steps 1 and 2 in the Getting the Sample Code section above.
  6. In Import wizard, press Select All button.

    Import archive wizard

  7. Make sure that the Example project appears in the destination Into folder field. Then click Finish.
  8. In the Product Explorer view, expand the project and the as_dev_tools product folder to view the modules.

    Product Explorer view

Related concepts

Magik projects
Magik views

Related reference

New Magik Project Wizard
Product Explorer View