MDT on Facebook MDT on Twitter

SW5 Support Plug-in 1.1.1 released!

2017-07-21 12:00

A new version of the MDT SW5 Support Plug-in has been released, which now also supports Smallworld 5.1.1 and 5.1.2. Read more about the changes on the List of Changes page.

Go back