Page 1 of 1

eclipse 4.3 (kepler) support

PostPosted: 11 Mar 2014, 08:50
by lczub
MDT 3.4 release notes only reference the "old" eclipse 4.2 (juno).
Is it possible to use MDT 3.4 plugins with eclipse 4.3 (kepler) or are there any plans to support it?
Greetings Luiko

Re: eclipse 4.3 (kepler) support

PostPosted: 11 Mar 2014, 11:05
by Bartek
Hello Luiko,

We are working on it but as far as I know you should not have any problems while using MDT 3.4 on Eclipse 4.3. One of our Smallworld Magik developers is working in this configuration for a long time and he didn't notice any problems. Nonetheless there is only one small problem after installing MDT 3.4 on Eclipse 4.3 - the default "Magik Development" perspective is not being set up as it should. You will have to manually add some views to default perspective (To be sure that everything is fine, close all the views in default perspective and add the ones you need with the use of Window -> Show View... action).

Full compatibility with Eclipse 4.3 (and 4.4 if it will be available at the time) is planned to be added in MDT 3.5 release.

With best regards.

Re: eclipse 4.3 (kepler) support

PostPosted: 12 Mar 2014, 08:34
by lczub
Hello Bartek,
thanks for this good news. I will try it
Luiko

Re: eclipse 4.3 (kepler) support

PostPosted: 14 Mar 2014, 14:01
by lczub
Hello Bartek,

just for information, the MDT 3.4 PE plugin installation into eclipse-4.3-jee_64bit-SR2 fails with following message

Cannot complete the install because some dependencies are not satisfiable
pl.com.astec.mdt.feature.group [3.4.0.PE-20131114-1650] cannot be installed in this environment because its filter is not applicable.

I could work with eclipse-4.2-jee + MDT PE 3.4 so there is nothing to do on your site.

Greetings Luiko

Re: eclipse 4.3 (kepler) support

PostPosted: 17 Mar 2014, 10:01
by Bartek
Hello Luiko,

MDT won't work in this configuration because it is not yet compatible with 64-bit version of Eclipse. You can work with Eclipse 4.3 but you have to use 32-bit release.

With best regards.

Re: eclipse 4.3 (kepler) support

PostPosted: 21 Mar 2014, 13:31
by lczub
Hello Bartek,

thanks for the hint.
With 32bit version of ecplise 4.3 jee it works really.

Greetings Luiko